1. #1

    Join Date
    May 2012
    Location
    lompoc
    Posts
    6

    Default Penn electric 820 downrigger

    While loading braid line on it kept shutting it self off. The breaker wasn't popping. Every 2-15 second had to start again. Wonder if anyone knows anything about these. Pc board, motor? Might have to try at 35 feet to see if it might work, till I can trust it. Time for Scotty. Well might be ok. Cleaned up electrical connections and seems to be working fine. Time to test it out soon. Tight lines, sharp hooks. Good luck everyone.
    Last edited by clark; 04-03-2019 at 10:09 AM.

  2. #2

    Join Date
    Sep 2014
    Location
    lompoc
    Posts
    70

    Default

    So is it fixed?

  3. #3

    Join Date
    May 2012
    Location
    lompoc
    Posts
    6

    Default

    Hopefully it is fixed. Might have been bad connection. After cleaning I could run motor putting resistance on spool and would keep running. Time for a real test, hopefully next weekend.

  4. #4

    Join Date
    Sep 2014
    Location
    lompoc
    Posts
    70

    Default

    winds going to blow till next weekend

  5. #5

    Join Date
    May 2012
    Location
    lompoc
    Posts
    6

    Default

    Hopefully going next Sunday, Monday or Tuesday.

  6. #6

    Join Date
    Sep 2014
    Location
    lompoc
    Posts
    70

    Default

    Im going to be fishing cachuma, Got the trout derby coming up and its a whole different lake than last year.
    Then its all about salmon

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in